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ABSTRACT 
Effective control during the construction phase is very important for the overall success of a 
project. The ability to diagnose the causes of unsatisfactory performance forms a critical part 
of the foundation of good construction control practice. Based on an extensive literature 
review, it is observed that the majority of research efforts to date have focused on developing 
predictive construction performance models as opposed to explanatory ones, and several 
important issues relevant to diagnosing construction performance have not been addressed or 
sufficiently emphasized. Described in this paper is a conceptual construction performance 
diagnosis schema that is applicable to a broad range of performance measures. Important 
factors for time as a representative performance measure are identified and discussed along 
with the issue of mapping these factors onto data typically collected in support of ongoing 
management functions. Then, issues pertaining to the practical formulation and application of 
formally structured causal models for diagnosing construction performance are discussed. An 
overview of the diagnosis schema proposed is provided, followed by its application to an 
example project.  
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INTRODUCTION  
It is not uncommon to observe discrepancies or variances between the values of planned and 
actual construction performance measures such as cost, time, scope, productivity, quality and 
safety. Further, it is often not clear if a performance variance results from inaccurate planning, 
poor construction management practice, events beyond the contractor’s control, or some 
combination thereof. The academic community has expended considerable effort to reduce or 
eliminate completely such discrepancies by developing improved management tools. These 
efforts can be divided into two lines of inquiry. The first assumes that the discrepancy mainly 
comes from inaccurate planning, leading to the development of predictive models for 
performance to improve the accuracy of estimation. By predictive models we mean models 
that can be used to provide or ‘predict’ a priori accurate estimates of performance measure 
achievements, given an estimate of the likely state of a set of factors that are believed to be 
relevant for the work scope and performance measure of interest. Values used are assumed to 
represent an average of the conditions forecast to be encountered (e.g. labour skill level). 
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Such models are useful in the estimating phase of a project and assist in providing 
benchmarks for project control. In contrast, the second line of inquiry assumes that the 
discrepancy mainly results from poor construction management practice and events beyond 
the contractor’s control. Thus, researchers have focused on developing explanatory models to 
help practitioners identify plausible causes for unsatisfactory achievements. By explanatory 
models we mean those that can help construction personnel figure out what the most 
plausible explanation is for a deviation of actual performance from expected performance, 
given relevant actual project data collected during the construction phase. As compared to 
predictive models, the body of research on explanatory models is very limited.  

Presented in this paper are selected aspects of a conceptual framework for diagnosing 
reasons for various dimensions of actual construction performance deviating from what was 
planned. Because of space constraints, time performance at the project level (i.e. project 
duration) is selected as a representative performance measure for explaining issues associated 
with diagnosing reasons for performance, and features of the approach being pursued. A list 
of factors identified in the literature as affecting time performance is presented along with a 
mapping of these factors onto data items typically collected as part of ongoing management 
functions. Then, important practical issues pertaining to the formulation and application of 
formally structured causal models for diagnosing construction performance are discussed. An 
overview of the diagnosis schema proposed is then provided, followed by its application to 
an example project.  

LITERATURE REVIEW 
An extensive literature review was carried out to survey the state-of-the-art of predictive and 
explanatory construction performance models, as well as critical factors having impact on 
different construction performance measures (Korde et al. 2005). These papers have been 
categorized in terms of performance measure treated (e.g. productivity, time, cost, quality, 
safety), performance level treated (activity level, trade level, project level), method used (e.g. 
regression, neural networks, fuzzy logic, importance index, decision support system), type of 
model (predictive, explanatory), and factors that influence performance measures.  

Findings from the literature search have provided a useful point of departure for pursuit 
of our research goal, which is to develop an approach for construction users to define 
experience-based hypotheses about explanations for performance achieved in terms of 
formally structured causal models that make use of data already collected as an essential part 
of day-to-day management functions. Such hypotheses can be used to guide searches of a 
project’s data base in order to find evidence in support of these hypotheses. To develop them, 
factors having impact on various performance measures or their constituents need to be 
identified. Based on the literature search, unanimous consensus on the list of critical factors 
affecting different performance measures was not found. We used a simple frequency test to 
determine factors for which there was a reasonable level of consensus. The test consisted of 
identifying those factors which were listed in at least 20 percent (a rather lenient threshold) 
of the papers relevant to that performance measure.  

For time performance or project duration, of the 134 papers identified to date, 41 of them 
focus on it. For this measure a factor is regarded as being important only if at least 9 of these 
41 papers regarded it as important. Using this criterion, 15 factors were identified, as shown 
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in Table 1. The terminology used to express these factors is the authors, as no consistent 
terminology was employed in the literature. Further, for each factor identified, a number of 
sub-factors were presented by various authors. These are shown in Table 1 as well, and again 
we have attempted to capture different ways of saying the same thing in a consistent manner. 
Important to us is ensuring that these factors/sub-factors are represented in our diagnostic 
schema, to the extent possible. Besides knowing what factors/sub-factors are important, it is 
also necessary to know how their states can be expressed. Unfortunately, little discussion of 
this issue can be found in the papers reviewed. 

As noted previously, we have sought to build on the collective wisdom found in the 
literature. As a first step we have mapped factors and sub-factors found in the literature onto 
data normally collected in support of ongoing management functions in order to make sure 
they are represented directly or indirectly through surrogates in the project data base.  
Corresponding data fields are reflected in a multi-view representation of a project (Russell 
and Udaipurwala 2004), or can be derived through operations on one or more data fields. The 
views treated include physical, process, organizational/contractual, environmental, quality, 
cost, as-built, change and risk. In general, the data used to represent these views (e.g. 
schedule, weather, labour data, etc.) embrace many of the factors/sub-factors identified in the 
literature. Examples of such mappings are presented in the bottom of Table 1. 

CAUSAL MODELS 
We have adopted a causal model approach to assist with the diagnosis of construction 
performance for three main reasons: (i) we wish to empower management personnel to be 
able to easily encode their knowledge and experience in a very hands on and transparent 
manner; (ii) we seek an approach that is applicable to a broad range of performance measures 
and which provides leverage in terms of allowing reuse of models for lower level measures 
to generate more extended models for higher level measures; and (iii) we want an approach 
that does not require the processing of extensive data sets from past projects using analysis 
techniques unfamiliar to industry personnel. In using causal models to reason about 
performance, we do not seek answers to the question: how much of the variance in 
performance measure y can be explained by factor x? Rather, our goal is more modest: we 
wish to find any evidence that supports the hypotheses embedded in the causal model – i.e. 
these factors are the determinants of the level of performance.  

Cause-effect diagrams have been used by other researchers to study different construction 
performance measures (e.g. Abu-Hijleh 1991; Diekmann and Al-Tabtabai 1992; Moselhi et 
al. 2004). Nevertheless, an in-depth discussion of how best to structure such diagrams and 
issues inherent in their use have not been the focus of these researchers. Figure 1 illustrates 
the general form we have adopted for expressing a causal model. It is comprised of three 
main layers: (1) the performance measure of interest; (2) fundamental or mathematical 
relationships for determining the value of the performance measures; and, (3) factor causal 
models that represent hypotheses to explain performance for each of the variables in layer 2.  
We elaborate on each of these layers in the context of time performance of a project, in order 
to highlight a number of important topics dealing with efficiency of the search /diagnostic 
process, the requirement for multiple causal models, the desired form of these models, and 
the source of values for the factors. As noted previously, we could have chosen to examine  
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Table 1 Factors/Sub-Factors and Mapping onto Data Collected (Time Performance) 

Factors affecting time performance Factors affecting time performance 
Factors Sub-Factors Factors Sub-Factors 

Labor skill Planning effort 
Labor availability Planning deficiency 
Technical/Mgmt. staff skill 

Planning 
(13/41) Inadequate early planning 

Human 
resource 

management 
(20/41) Technical/Mgmt. staff availability Quality of drawings 

Design changes Quality of specifications 
Material changes 

Mistakes 
(12/41) Construction mistakes 

Specification changes Contract type 
Construction method changes 

Contract Mgmt. 
(12/41) Unrealistic schedule objective 

Changes orders
(16/41) 

Frequency of changes Portion of subcontract 
Precipitation Subcontractor delay 
Temperature Nominated subcontractor or not Weather 

(14/41) Wind 

Subcontractor 
(11/41) 

Bankruptcy of subcontractor 
Material availability Efficiency of delay control 
Material delivery 

Schedule control 
(10/41) Schedule update frequency 

Material quality Inadequate fund 
Material damage 

Contractor’s finance 
(9/41) Timely payment for finished work 

Material 
management 

(14/41) 
Material storage (loss/theft) Communication (9/41) Inadequate/Inefficient communication  
Equipment availability Strike 
Equipment delivery 

External Environment 
(9/41) Unexpected event (e.g. ground cond.) 

Equipment quality (breakdown) Delay in design information 

Equipment 
(tools) 

management 
(13/41) Unskilled equipment operators  

Engineering(design) 
(9/41) Design effort (cost, duration) 

Labor productivity   Productivity 
(13/41) Equipment productivity 

 

  
Labor skill As-built View>Daily Site>Daily Status Data>Work Force>Skill level 
Precipitation As-built View>Daily Site>Site Environment Data>Precipitation (mm) 
Equipment availability Process View>Resources>Resource Data>Availability 
Material damage Process View>Resources>Resource Data>Project Records/Memo 
Quality of drawings Physical View>Drawing control; As-built View > RFIs 
Timely payment for work Cost View>Pay item breakdown structure>Pay item data>Scope/cost/Act. 
Communication  Organizational View>Participants>Add./Info.>Evaluation>Communication 

Mapping 
Examples 

Material quality Quality View>Quality Management  
 

other measures or a subset of a more global measure – e.g. duration of a single activity. For 
this, only a subset of figure 1 is required, as shown by the shaded elements of figure 1.  

The first layer of the causal model determines if there is a need to invoke use of the 
causal model – i.e. explain a variance between planned vs. actual performance. The second 
layer deals with the relationships used to compute values for the first layer performance 
measure. Not all measures (e.g. safety) can be expressed through fundamental 
relationships, and hence the second layer is not applicable for all performance measures of 
interest.  For the case at hand, the basic relationships that describe time performance can be 
broken down into a number of sub-layers. Sub-layer 2(a) corresponds to the network of 
critical activities and paths which are the determinants of project duration.  Thus, sub-layer 
2(a) helps narrow the breadth of the diagnosis that has to be conducted. Sub-layers 2(b) and 2(c) 
help pinpoint which activities / precedence relationships amongst the critical ones are the 
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Figure 1: Cause-Effect Diagram for Construction Time Performance 
 
determinants of the variance in time performance. Thus checks are run on the duration and 
start and finish date variances of all critical activities to identify the items requiring further 
investigation. These checks can all be performed using quantitative data from the base 
schedule and the current updated schedule.  The only non-quantitative check made occurs in 
sub-layer 2(c) and it relates to the notion of implicit predecessors – e.g. were the required 
permits in place and was the space required for the work accessible. Diagnosis of this 
variable for activities requiring further analysis is conducted by a causal model of relevant 
factors, as shown in layer 3 – only a subset of relevant factors is shown in figure 1. Sub-
layers 2(d) and 2(e) deal with the analysis of an activity’s duration, and makes use of another 
fundamental relationship, activity duration D (days) equals scope Q (e.g. m3) divided by the 
product of productivity P (e.g. m3/mhr) and resource usage rate R (e.g. mhr/day) or 
production rate Pr (e.g. m3/day) which is the product of P and R (alternatively, one could 
choose to work directly with a causal model for activity duration without consideration of its 
constituent variables). Using the former for purposes of discussion, actual duration Da of an 
activity is equal to working time plus idle time. Again, we seek to pinpoint the basis for 
activity duration variance. If actual working time corresponds to what was planned, but 
considerable idle time (IT) was encountered, then to explain idle time another causal model 
is used, with the factors considered for idle time being relevant to the type of work performed.  
Alternatively, if variances are found in one or more of Q, P or R, then the appropriate causal 
models for each of the variables are explored to see if they explain the variance. Layer 3 
corresponds to the causal models themselves, which represent the knowledge and experience 
of construction personnel, expressed in terms of data collected directly or derived from data 
collected in support of construction management functions.  It is here that we wish to make 
sure that the factors considered embrace factors / sub-factors identified as being important in 
the literature. Key challenges deal with how to let construction personnel formulate these 
models and factor states / thresholds simply and in an easily comprehendible way.  

Based on the foregoing discussion, and so that a practical approach can be developed for 
diagnosing reasons for performance that is applicable to a broad range of measures, a number 
of assumptions have to be made and several important issues addressed, as follows: 
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• Planning and control at the same level of detail: The diagnostic schema proposed 
assumes that planning and control will be conducted at the same level of detail. 

• Overall framework: An overall framework needs to be formulated that minimizes the 
burden on users for setting up the diagnostic process for the measure of interest. Ease 
of use and transparency of approach are essential to influence actual practice. 

• Modular approach: The approach should be as modular as possible, allowing reuse of 
lower level models for higher level ones. 

• Factor interaction and single layer causal models: In formulating causal models, it is 
possible to generate models that involve many factors along with complex 
interactions amongst them. What is not clear is how to account for these interactions, 
especially with respect to combinations of factor states. We have opted for single 
layer models because they can be readily specified by construction personnel with 
access to the full set of factors for which data is collected.  

• Values or states of factors in causal models: A major challenge is how to define and 
compute states of factors to determine if they are a possible driver of poor 
performance. Factors can be classified into at least two types: (i) those that have a 
direct influence on performance – e.g. the factor of labour skill level on productivity; 
and (ii) those that have an indirect influence on performance and which are assessed 
through one or more surrogate measures – e.g. the factor of drawing quality which 
may be assessed through number of drawing revisions and number of RFIs.  For the 
first type of factor, one has to determine how best to express the factor and how to 
aggregate through time.  For the second type of factor, some kind of index needs to 
be determined that reflects the norm in the industry vs. what is experienced on the 
project at hand. A paucity of such benchmarks is available in the literature. 

• Ability to function with missing or erroneous data: A reality of the industry is that 
data sets are incomplete, and data recording errors occur. The diagnostic process still 
has to function, even if it means simply reporting that no data had been recorded for 
one or more factors. 

• Classification of causal models: It is important to avoid a proliferation of causal 
models. Models should be categorized by performance measure of interest, and 
within a measure, models can be developed to reflect types of work – e.g. 
unprotected vs. a protected work environment, and labour vs. equipment intensive. 

• Ability to conduct analysis on the search results: For measures at the trade or project 
levels, once a search has been conducted for evidence to explain performance, an 
analysis should be conducted to identify factors common to multiple variables. 

OVERVIEW OF PROPOSED APPROACH 
In this section, we overview the four main components of our construction performance 
diagnostic approach, as illustrated in figure 2: (1) the project data base that contains factor 
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values and other performance related data; (2) a library of causal models; (3) a hypothesis 
generating, search and reporting component; and (4) a data visualization component. 

The project data base component, as illustrated in figure 2, is the source of factor values, 
which can be organized in a hierarchical fashion (indicated as categories, factors, sub-factors 
in figure 2). The causal models are formed using the lowest level in the hierarchy. We 
observe that for the case of sub-factors, there is no obvious way to integrate across different 
sub-factors to create some kind of index at the factor level that represents the combined 
effects of the sub-factors. An underlying assumption of our approach is access to the 
necessary data either through a fully integrated system that supports multiple construction 
management functions or through an environment which supports interoperability of various 
applications in support of these functions.  We use the former approach herein. 

The second component of the approach corresponds to a library of causal models 
expressed in terms of the factors contained in the first component, as shown on the right hand 
side of figure 2. Central to this component is a user interface which allows ready access to 
these factors, a simple way of defining and editing a causal model and relevant meta data, 
and an effective way of organizing the models developed. We believe that the most useful 
way to organize the library is in the form of a hierarchy, with the first level in the hierarchy 
corresponding to basic performance variables/measures as shown. Under each performance 
variable, a number of factor models can be formulated by practitioners to represent different 
working contexts (e.g. for activities, protected vs. unprotected work). Also included as 
applicable would be default casual models which reflect findings in the literature. By 
organizing the models in the manner suggested, it is possible to compose higher level models 
from lower level ones. Then, if the request as part of the query process in the third 
component of the approach is to find any and all evidence in support of the causal models 
used for diagnosing reasons for extended project duration, then a higher level causal model 
could be assembled in accordance with figure 1. 

Figure 2. Main Components of Approach to Diagnosing Reasons for Performance 
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As shown in the upper left hand side of figure 2, the third component relates to the actual 
search for data in support of the performance hypothesis of interest. Steps in this process are 
basically self explanatory and consist of: (i) selecting the performance measure to be 
examined (e.g. project duration); (ii) choosing the system entities of interest (e.g. all critical 
activities); (iii) specifying filters as to the breadth of the query in terms of one or more of 
time frame, spatial dimension and project participants of interest (e.g. for our project duration 
measure, set the time frame to be project start to time of last schedule update); (iv) 
selecting/developing the relevant causal model from the library of causal models either 
manually or with assistance by the system depending on the level of information specified by 
the system user and specify relevant user tests and corresponding thresholds for factors as 
appropriate; and (v) executing the search for supporting evidence and presenting it in various 
user specified reporting formats. 

Finally, while not central to our approach, a fourth component, as shown in the lower left 
hand corner of figure 2 relates to the ability to visualize project data. Such a capability can 
assist with the inspection of masses of data as part of the process of formulating causal 
models, and for viewing evidence found as part of the search process in component 3.  

APPLICATION OF APPROACH TO AN EXAMPLE PROJECT 
In this section, we demonstrate selected aspects of our approach by way of its application to 
an example project which consists of a 6 story residential building and single level 
underground parkade. The current construction market is very hot, with shortages of labour 
occurring in several key trades, and overburdened design offices. Notice to Proceed was 
received in time for a 20 October 2003 start of fieldwork. The project must be completed no 
later than 31 August 2004. Since the project is being built in a relatively quiet residential area, 
working hours must conform strictly to existing by-law requirements. As per the 
geotechnical report, the potential for encountering large size boulders was noted. The 
expectation was that the chances of encountering contaminated soil were low to very low. A 
shotcrete shoring system was specified, and it was anticipated that surrounding soil would 
provide good anchorage for the anchoring rods. Unfortunately, not all of the expectations 
have been met, and in addition, the weather has proved to be atypically bad for this time of 
year. It is now 28 November 2003, and to date work has not progressed well. While the 
original scheduled completion date was 31 August 2004, the new projected completion date 
is 21 September 2004, assuming no revisions are made to the schedule to make up lost time. 
Using an extended causal model that conforms to the structure of figure 1, the contractor wants 
to find all evidence in the project data base to the effect that the causal model factors explain 
performance to date. 

From the project description it is observed that there is an unacceptable variance in 
project duration (step 1 in figure 1). Thus, the next step (2a) involves identifying the critical 
activities and paths. This step relates to the upper left hand component in figure 2, in which 
project duration has been selected as the performance measure, all critical activities have 
been selected, a time window of 20 October (project start) to 28 November 2003 (current 
progress date) has been selected, and activity duration causal models from the causal model 
library selected for unprotected, equipment intensive, substructure work.  The analysis that 
relates to steps 2(b) and 2(c) is then conducted in order to narrow the search for factors that 
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describe performance. Partial results from this analysis are shown in Table 2. Only one 
activity, Bulk Excavation, shown shaded in Table 2 is identified for further investigation (our 
example is intentionally simple because of space constraints).  Based on the profile specified 
in the upper left hand component in figure 2, the appropriate casual model is selected, as 
shown on the left hand side of figure 3. This model is meant to be defined by construction 
personnel, using the factors contained in the project data base. These factors are shown on 
the right hand side of figure 3, organized first by project view, then categories and 
subcategories of factors, and then the factors themselves. The source of the factors specified 
is the as-built view of the project. A visual representation of two causal model factors and 
activity status on a daily basis is shown in figure 4. Given a specification of thresholds by the 
user for various factors (e.g. precipitation levels), then the search process will explore the 
project data base and find which factors of the ones identified in the causal model, along with 
their associated values and links to other information (e.g. correspondence, photos, etc.), 
explain, at least in part, reasons for performance to date. 

Table 2. Critical Activities and Their Properties 

Act. 
Code Act. Description Location Critical 

Activity
Pred. 

Relation
Pred. 

Variance
Start 

Variance 
(days)

Duration 
Variance 

(days) 

Idle 
Time 

(days) 

Finish 
Variance 

(days)
01 Receipt of notice to proceed GLOB Y N/A N/A 0 0 0 0 
02 Mobilize and clear site SITE Y 01(FS0)* 0 0 0 0 0 
03 Bulk excavate substructure PKDE Y 02(FS0)* 0 0 [11] [4] [11] 

04 Shotcrete shoring PKDE Y 03(SS2)*
03(FF2) 

0 
[11] 2 4 2 6 

05 Excavate footings FDN Y 03(FS0)* [11] 6 [0] [0] [6] 

06.01 F/P/S perimeter wall footings FDN Y 

05(SS2)*
05(FF5) 
04(FS0)*
44(FS0)

6 
[6] 
6 

[1] 

5 [0] [0] [5] 

06.03 F/P/S column footings FDN Y 06.01(SS2)* 5 4 [0] [0] [4] 

Figure 3. Formulation of Causal Model for Activity Duration 

Physical

Process

As-built

Organization

Site Environment Data

Activity Data

Temperature (oC)
Precipitation (mm)

PCBS

Drawing Control

Actual = planned?
 (e.g. contaminated soil : yes ‡ no)

View Layer Component Layer Factor Layer

Records

Daily Site

Wind (Kph)
Ground condition (good/fair/poor)

Access to site (good/fair/poor)

Status (finished/idle/…/ongoing)
Problems 

No. of workers
No. of supervisors

Skill level (high/medium/low)

Work Force 
Equipment 
Pay Items 

Changes

1.1... 
1.2...n.m 

Precipitation 

Activity Duration 
(unprotected; 

equip. intensive; 
substructure phase) 

Ground condition 
Access to site 

2.07 Unexp Geotech Condtns 

2.08 Contaminated Soil 
07.03 Insufficient Equipment

07.06 Equipment Breakdown

09.01 Unanticipated Utilities

2.06 Poor Ground Conditions 

Activity Duration Causal model 

Quality Management 
Attributes 

Organization of Causal Model Factors 
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Figure 4. Data in As-Built View 

CONCLUSIONS 
In this paper the authors have designed a comprehensive schema for diagnosing reasons for 
performance for a broad spectrum of performance measures. Central to the schema is the 
ability to capture the diagnostic expertise of seasoned construction personnel in the form of 
causal models which build on data collected in support of management functions. Factors 
deemed to be important by other researchers for predicting and explaining construction 
performance are treated, either directly or through related surrogate measures. Ongoing work 
is directed at eliciting causal models from construction experts in combination with 
continued exploration of the literature, determining meaningful tests for factor values in 
order to assess when negative states of a factor will impact performance, implementing the 
causal model library component and data search aspects of the schema, and demonstrating 
the efficacy of the approach using actual project data.  
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